Составьте программу для вычисления значения выражения x в степени n + y в степени m. значения x,y,n,m > 0 вводятся с клавиатуры. примечание: чтобы возвести число в n-ную степень, надо его умножить само на себя n раз.

davideblan33 davideblan33    3   23.06.2019 07:00    0

Ответы
akaspiyskaya akaspiyskaya  19.07.2020 09:00
Begin
var x, y, n, m: integer;
Readln(x, y, n, m);
Assert((x > 0) and (y > 0) and (n > 0) and (m > 0));
var upstep: integer := n + y;
for var i := 2 to m do
upstep *= (n + y);
var lowstep := x;
for var j := 2 to upstep do
lowstep *= x;
Writeln(lowstep);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика