Составить программу вычисления функции на языке паскаль (a+b)/ (e^-x+sin(x)) t={ (a+b)/(x+1) e^-x+sin(x) условие: x< 2.8; 2.8< =x< 6; x> =6 исходные данные: a=2.1; b=-0.29 шаг изменения: x принадлежит [0; 7]; дельта x=0.5

NastysikRicci NastysikRicci    2   19.05.2019 04:10    0

Ответы
nikzakora nikzakora  12.06.2020 09:11

program lol;
var
a,b,x:real;
shag:real;
T:real;
begin
Shag:=0.5;
a:=2.1;
b:=-0.29;
x:=0;
While x<=7 do
begin
If x<2.8 then
T:=(a+b)/exp(-x)+sin(x);
If (2.8<=x) and (x<6) then
T:=(A+B)/(x+1);
If X>=6 then
t:=exp(-x)+Sin(X);
Writeln('при Х=',x,'  T=',t:4:2);
X:=x+shag;

end;

end.

 

 

 

надеюсь Если что нетак пиши 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика