Составить программу в pascal help ! подготовка к в тексте, состоящем из 3 слов, проверить, есть ли заданное слово и сколько раз оно повторяется. если такого слова нет, то выдать сообщение.
begin Write('Введите текст из трех слов: '); Readln(s); Write('Введите искомое слово: '); Readln(w); ls := Length(s); lw := Length(w); n := 0; i := 1; p := Pos(w, s); while p > 0 do begin n := n + 1; i := p + lw + 1; s := Copy(s, i, ls - i + 1); ls := Length(s); p := Pos(w, s) end; if n = 0 then Writeln('Искомое слово не встречается в тексте') else if n = 1 then Writeln('Искомое слово встречается 1 раз') else Writeln('Искомое слово встречается ', n, ' раза') end.
Тестовое решение:
Введите текст из трех слов: Мама мыла раму Введите искомое слово: Папа Искомое слово не встречается в тексте
Введите текст из трех слов: Мама мыла раму Введите искомое слово: мыла Искомое слово встречается 1 раз
Введите текст из трех слов: ааа ааа Введите искомое слово: ааа Искомое слово встречается 2 раза
s, w: string;
i, ls, lw, p, n: integer;
begin
Write('Введите текст из трех слов: ');
Readln(s);
Write('Введите искомое слово: ');
Readln(w);
ls := Length(s);
lw := Length(w);
n := 0;
i := 1;
p := Pos(w, s);
while p > 0 do
begin
n := n + 1;
i := p + lw + 1;
s := Copy(s, i, ls - i + 1);
ls := Length(s);
p := Pos(w, s)
end;
if n = 0 then Writeln('Искомое слово не встречается в тексте')
else if n = 1 then Writeln('Искомое слово встречается 1 раз')
else Writeln('Искомое слово встречается ', n, ' раза')
end.
Тестовое решение:
Введите текст из трех слов: Мама мыла раму
Введите искомое слово: Папа
Искомое слово не встречается в тексте
Введите текст из трех слов: Мама мыла раму
Введите искомое слово: мыла
Искомое слово встречается 1 раз
Введите текст из трех слов: ааа ааа
Введите искомое слово: ааа
Искомое слово встречается 2 раза