tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу на
Составить программу на языке c++! дано натуральное число n. выведите слово yes, если число n является точной степенью двойки, или слово no в противном случае. операцией возведения в степень пользоваться нельзя!
arinahovhannisyan1
3 10.09.2019 21:30
7
Ответы
DashaGaff
07.10.2020 06:09
#include <bits/stdc++.h>
using namespace std;
int main(){
int n;
cin >> n;
if (n <= 0)
{
cout << "NO";
return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
cout << "YES";
else
cout << "NO";
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kristiniiiiiii
08.11.2020 13:21
решить информатику задание в прикрепленном фале ) 1.Написать задание. 2. Написать программу. 3. Нарисовать блок схему. 4. Оставить немного места под результат...
morshchininao
08.11.2020 13:20
Реферат на тему поняття навчального середовища...
Sheva031
19.02.2020 21:42
Назовите команду ОС Windows, с которой можно посмотреть NDP-таблицу рабочей станции?...
Nikolayirh
19.02.2020 21:44
Через какое устройство происходит обмен информацией между устройствами компьютера...
Feraaa2108
06.09.2020 21:59
Напишите программу, которая считывает названия трёх книг по одному в строке и выводит их в обратном порядке, тоже по одному в строке. На C++...
BazikPro
06.09.2020 22:18
Составить программу с оператором case , которая определяет день недели(пн(1)...вс(7)), всего дней 366...
vachevardanyan
07.09.2020 00:30
Создайте программу на Pascal ABC! Два последовательных двузначных числа сложили и в их сумме переставили цифры. В результате получилось большее из складываемых...
xxx5639
07.09.2020 00:32
В одной из кодировок каждый символ кодируется двумя байтами...
Lyadavinchi
07.09.2020 00:34
Не могу войти в iCloud пишет активировано предельное количество учётных записей , что делать? Как войти?...
antoshkaromanov
07.09.2020 00:28
с информатикой в рабочей тетради когда в школе объявили день вежливости каждый мальчик из 5 а класса поздоровался с каждой девочкой из всего класса. всего при этом...
Популярные вопросы
Решите и составьте для неё решетку пеннета резус-положительная...
2
Я, кстати, спрашивал у марь иванны, она у нас будет вести профиль...
1
Какие перья у вороны, голубя и глухаря. если есть ответ, то...
3
Для изобарного процесса из перечисленных утверждений: 1) вся...
3
Стая пингвинов может съесть 200 кг криля за трое суток. за какое...
3
4наборов букв переставьте буквы так чтобы получились слова обозначающие...
3
Таблица экологические группы птиц. в таблицу входят столбики...
1
Специализированных магазинах предлагают на продажу грибницы...
3
Нужна авторская работа! нужно ответить на вопросы по отрывку...
2
20 составьте выражения, которые можно разложить на множители...
1
using namespace std;
int main(){
int n;
cin >> n;
if (n <= 0)
{
cout << "NO";
return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
cout << "YES";
else
cout << "NO";
}