Составить программу, которая по сумме цифр определит делится ли число на

sanek48rus1 sanek48rus1    1   28.08.2019 04:00    0

Ответы
123456123свет23415а 123456123свет23415а  05.10.2020 23:57
Function Div3(n:longint):boolean;
var s:byte;
begin
s:=0;
while n>0 do 
begin 
s:=s+n mod 10; 
n:=n div 10; 
end;
if s mod 3=0 then Div3:=true
else Div3:=false;
end;

var a:longint;
begin
write('Введите a: ');
readln(a);
if Div3(a) then write('Число делится на 3')
else write('Число не делится на 3');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика