Составить программу, которая бы определяла с гласной ли буквы начинается введенное слово и определить первая буква совпадает с заданной . в паскале

NoirShade NoirShade    2   05.09.2019 21:00    0

Ответы
Kaldomova2014 Kaldomova2014  06.10.2020 20:00
// PascalABC.NET 3.3, сборка 1540 от 16.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите слово:').ToLower;
  var c:=ReadlnChar('Введите букву:').ToLower;
  if Pos(s[1],'аеёиоуыэюя')>0 then Writeln('Слово начинается с гласной')
  else Writeln('Слово начинается не с гласной');
  If s[1]=c then Writeln('Слово начинается с указанной буквы')
  else Writeln('Слово не начинается с указанной буквы')
end.

Примеры
Введите слово: Арбуз
Введите букву: к
Слово начинается с гласной
Слово не начинается с указанной буквы

Введите слово: Барабан
Введите букву: б
Слово начинается не с гласной
Слово начинается с указанной буквы
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика