Составить программу: дан массив из 40, из него составить два массива, первый с четными положительными числами, а второй с остальными. рандом (-1000..1000) в паскале

co63upo co63upo    3   15.08.2019 00:20    1

Ответы
zroslama zroslama  04.10.2020 19:54
Const n=40;
var a,b,c:array [1..n] of integer;
i,i1,i2:integer;
begin
randomize;
for i:=1 to n do
 begin
 a[i]:=random(2001)-1000;
 write(a[i],' ');
 end;
writeln;
i1:=0; i2:=0;
for i:=1 to n do
 if (a[i] mod 2 = 0)and(a[i]>0)
  then begin i1:=i1+1; b[i1]:=a[i]; end
  else begin i2:=i2+1; c[i2]:=a[i]; end;
for i:=1 to i1 do write(b[i],' ');
writeln;
for i:=1 to i2 do write(c[i],' ');
writeln;
end.

Пример (для n=10):
46 -695 764 502 965 253 454 180 -123 980 
46 764 502 454 180 980 
-695 965 253 -123 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика