Синформатикой напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.
Var a:array[1..20] of integer; i,min,ind:integer; begin randomize; for i:=1 to 20 do begin a[i]:=random(100)+100; write(a[i]:4); end; writeln; min:=a[1]+a[2]; for i:=2 to 19 do if a[i]+a[i+1]<min then begin min:=a[i]+a[i+1]; ind:=i; end; write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом'); end.
for(int i = 0; i< 20; i++){
a[i]=rand()%101+100;
}
int pos=0;
for(int i = 0; i< 20; i++){
if(a[i]+a[i+1]<a[pos]+a[pos+1]){
pos=i;
}
i,min,ind:integer;
begin
randomize;
for i:=1 to 20 do begin
a[i]:=random(100)+100;
write(a[i]:4);
end;
writeln;
min:=a[1]+a[2];
for i:=2 to 19 do
if a[i]+a[i+1]<min then
begin
min:=a[i]+a[i+1];
ind:=i;
end;
write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом');
end.