С++ напишите программу, которая выводит на экран все цифры числа, начиная с первой. допустим, вводишь 123, а программа выводит 1 2 3.

alica123434 alica123434    1   19.09.2019 10:20    7

Ответы
SpaceRZX SpaceRZX  08.10.2020 02:00
Один из простых методов.
#include <iostream>
void digits(const unsigned &val)
{
    if (val) {
        std::cout << (digits(val / 10), val % 10) << "  ";
    }
}
int main()
{
    digits(123);
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Саша08092005 Саша08092005  08.10.2020 02:00
#include <iostream>
#include <stack>

using namespace std;

void digits(int *num);

int main()
{
    int num;
    cin >> num;
    void(*ptr)(int *num);
    ptr = digits;
    (*ptr)(&num);
    return 0;
}
void digits(int *num)
{
    stack<short int> stack;
    while(*num>0)
    {
        stack.push(*num % 10);
        *num /= 10;
    }
    while(!stack.empty())
    {
        cout << stack.top() << " ";
        stack.pop();
    }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика