С++ написать программу перевода из десятичного числа в двоичное.

серго220 серго220    2   04.06.2019 12:20    10

Ответы
Черноболь666 Черноболь666  05.07.2020 13:02
#include <iostream>
using namespace std;

void bin(int n);
int main()
{
    int n;
    cout<<"Введи число в десятичной системе счисления\n";
    cin>>n;
    bin(n);
    system("pause");
    return 0;
}

void bin(int n)
{
     int binn[15], ;
     for(int i=14;i>=0; i--)
     {
             binn[i]=n % 2;
             n=n/2;
             }
    
     for(int i=0; i<=14;i++)
     {
             cout<<binn[i];
             }
      cout<<"\n";      
}            
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика