1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа, вводимого с клавиатуры. выводимому числу должно предшествовать сообщение «вы ввели число». 2. написать программу и составить к программе блок-схему. дано натуральное число. верно ли, что оно заканчивается нечётной цифрой. 3. написать программу и составить к программе блок-схему. составить программу вывода на экран «столбиком» четыре любых чисел. 4. написать программу и составить к программе блок-схему. дано трёхзначное число. определить, равен ли квадрат этого числа сумме кубов его цифр. 5. написать программу и составить к программе блок-схему. вычисления значения функции y=sin((3,2+sqrt(1+x))/abc(5x))

Dashakon58 Dashakon58    3   21.09.2019 21:40    25

Ответы
Daniel200011 Daniel200011  21.08.2020 13:05
Язык C++.
1. #include <iostream>
using namespace std;
int main() {
    int i;
    cout <<"Введите число: " << endl;
    cin >> i;
    cout << "Вы ввели число: " << i << endl;
    }

2. #include <iostream>
using namespace std;
int main (){
    int i;
    cout << "Vvod" << endl;
    cin >> i;
    i %= 10;
    if(i %2 != 0)
    cout << "Нечетная" << endl;
    else
    cout << "Четная" << endl;
    }

3. #include<iostream>
using namespace std;
int main (){
for(int k = 0; k<4; k++){
cout << "random number = " << rand() << endl;
}
}

4. #include <iostream>
using namespace std;
int main(){
int i,a,b,c;
cin >> i;
c = i%10;
b =(i/10)%10;
a = i/100;
if(i*i==a*a*a+b*b*b+c*c*c)
cout<<"Является."<<endl;
else 
cout<<"Не является."<<endl;
}

5. #include <iostream>
#include <cmath>
const double pi = 3.1415926536;
using namespace std;
int main(){
    float x = 0;    cout << "Введите x: " << endl;
    cin >> x;
    cout << "y = " <<  sin((pi*(3.2+(sqrt(1+x))))/180)/abs(5*x) << endl;
    }

Добавляем "pi" и делим на 180, чтобы "sin" был в градусах.

Блок-схемы смотри во вложении.
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика