Решите в паскале,! напишите программу,которая заполняет массив из n элементов случайными целыми числами в диапазоне [a,b] и определяет количество элементов этого массива,у которых сумма цифр равна k.

mamonova86 mamonova86    3   14.09.2019 20:30    4

Ответы
ученик11111023531 ученик11111023531  07.10.2020 15:10
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

function sn(n:integer):integer; // сумма цифр числа
begin
  n:=Abs(n);
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;

begin
  var (n,a,b):=ReadInteger3('Введите n,a,b через пробел:');
  var m:=ArrRandom(n,a,b); m.Println;
  var k:=ReadInteger('k=');
  Writeln('Найдено чисел: ',m.Where(t->sn(t)=k).Count)
end.

Пример
Введите n,a,b через пробел: 15 -50 60
43 2 42 -26 -34 57 45 44 29 -41 -4 1 -17 38 -19
k= 7
Найдено чисел: 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика