Решить на паскале.
с клавиатуры вводятся координаты точки на плоскости (x, y – действительные числа. написать программу, определяющую принадлежность точки заштрихованной области, включая ее границы.

marinadm9889 marinadm9889    1   29.10.2019 15:04    2

Ответы
Lisa2003black Lisa2003black  10.10.2020 10:08

program Test;

var

 x, y: Double;

begin

 WriteLn ('Введите координаты x и y: ');

 ReadLn (x, y);

 if (x >= 0) and (x <= Pi) and (y >= 0) and (y <= 0.5) and (y <= Sin (x)) then

   WriteLn ('Принадлежит')

 else

   WriteLn ('Не принадлежит');

 ReadLn;

end.

Объяснение:

Первые 4 условия проверяют прямоугольник от (0, 0) до (п, 0,5)

последнее условие проверяет левый и правый край этого прямоугольника на принадлежность к графику Sin (x)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика