tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решить 1) дан целочисленный
Решить 1) дан целочисленный массив, вывести на экран массив от наибольшего до наименьшего.
lera08862
2 13.08.2019 02:00
0
Ответы
katevyb
04.10.2020 14:49
// PascalABC.NET 3.2, сборка 1346 от 25.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
var a:=ArrRandom(Readinteger('n='),1,99); a.Println;
a.SortedDescending.Println
end.
Пример
n= 15
56 5 67 93 77 58 10 48 29 13 87 51 16 55 88
93 88 87 77 67 58 56 55 51 48 29 16 13 10 5
ПОКАЗАТЬ ОТВЕТЫ
annaglukhikh07
04.10.2020 14:49
Вот на языке С++
#include <iostream>
using namespace std;
int main(){ int n; cin >> n; int* arr = new int[n]; for (size_t i = 0; i < n; i++) { cin >> arr[i]; }
for (int i = 0; i < n - 1; i++) { bool swapped = false; for (int j = 0; j < n - i - 1; j++) { if (arr[j] < arr[j + 1]) { swap(arr[j], arr[j + 1]); swapped = true; } } if (!swapped) break; }
for (size_t i = 0; i < n; i++) { cout << arr[i] << " "; } cout << endl; return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
zalozhnik
05.06.2019 22:10
Напишите программу в паскале вычисления выражения: s=x^3+x^5+x^n, где x и n вводятся с клавиатуры. используйте функцию вычисления степени....
alyonaapresyan
05.06.2019 22:10
Решите ! в магазине действуют праздничные скидки. если стоимость покупки превышает 500 руб., то скидка составляет 5% от стоимости покупки. если стоимость превышает 1000руб.,...
Kетушка9
05.06.2019 22:20
Склавиатуры вводится матрица вещественных чисел размером n на m. n не превосходит 10, m не превосходит 20. найти и вывести номер первой строки, в которой все элементы нулевые....
Oclahoma
21.09.2020 03:16
триллинг и как реагировать на употребление иностранных слов в украинского язика привести пример неуместного употребление иностранных слов?...
ilmir123456789
21.09.2020 03:16
Як здійснювати пошук в Інтернеті...
marinaovechkina
21.09.2020 03:17
Перший потяг виїхав з пункту A в пункт B. Через деякий час з пункта A в тому самому напрямі виїхав другий потяг, швидкість якого на 30 км/год більша, ніж швидкість першого...
moiseenkooo
21.09.2020 03:17
Назначение и основные характеристики языка программирования С...
дима22819
21.04.2020 15:56
В одном саду собрали 198 ₓ яблок, а в другом 425y яблок. Всего в двух садах собрали 413₁₀ яблок. Определите, в каких системах счисления указаны исходные данные. Найдите...
Элис6666666666
02.12.2020 16:28
Необходимо написать код в Visual Basic для данной задачи при соблюдение всех условий. Вычислить значения функции по формуле z=1600 - piS/ x + y где постоянная pi=3,14 ;...
Alexandro1888
29.03.2019 02:10
Разобрать предложение по составу. скоро начнутся весенние каникулы....
Популярные вопросы
Рассчитайте массу осадка, полученного при взаимодействии избытка гидроксида...
2
Сравните дроби 4/15 и 0,13 здесь нужно сделать перевод...
1
Любимый герой в рассказе русалочка и...
3
Главные члены предложения: мне некогда не приходилось встречать такого...
2
Предложение с исконные и заимственные словами. в языке....
2
Решить , . если можете, на листке, как вам удобно. за раннее ! 10 ....
3
Найдите значение с если 1)-с=3,4 2)-с=-12 хелп...
3
7. а) найдите углы параллелограмма mnpk, изображенного нарисунке 31,...
1
Главные герои рассказа толстой кавказский пленник ответьте...
2
Определи наибольшее трёхзначное число выясни сколько всего однозначный...
3
// Внимание! Если программа не работает, обновите её версию!
begin
var a:=ArrRandom(Readinteger('n='),1,99); a.Println;
a.SortedDescending.Println
end.
Пример
n= 15
56 5 67 93 77 58 10 48 29 13 87 51 16 55 88
93 88 87 77 67 58 56 55 51 48 29 16 13 10 5
#include <iostream>
using namespace std;
int main(){ int n; cin >> n; int* arr = new int[n]; for (size_t i = 0; i < n; i++) { cin >> arr[i]; }
for (int i = 0; i < n - 1; i++) { bool swapped = false; for (int j = 0; j < n - i - 1; j++) { if (arr[j] < arr[j + 1]) { swap(arr[j], arr[j + 1]); swapped = true; } } if (!swapped) break; }
for (size_t i = 0; i < n; i++) { cout << arr[i] << " "; } cout << endl; return 0;}