Python
Можно с подробным объяснением.Я поняла как сортировать числа, но я не понимаю как их потом склеить..
Постоянная Капрекара
(Время: 1 сек. Память: 16 Мб Сложность: 22%)
Возьмем четырехзначное число, в котором не все цифры одинаковы, например 6264. Расположим цифры сначала в порядке убывания - 6642; затем, переставив их в обратном порядке, получим 2466. Вычтем последнее число из 6642. На следующем шаге с полученной разностью проделаем тоже самое. Через несколько таких действий получится число, переходящее само в себя и называемое постоянной Капрекара.

Требуется написать программу, которая находит эту постоянную и количество шагов для ее получения из заданного четырехзначного числа.

Входные данные
Входной файл INPUT.TXT содержит одну строку, в которой записано четырехзначное число.

Выходные данные
В выходной файл OUTPUT.TXT записываются: в первой строке постоянная Капрекара, во второй – количество шагов для ее получения.

lechyktvoeimamke lechyktvoeimamke    1   30.05.2020 10:59    8

Ответы
beauty227 beauty227  15.10.2020 11:04

int_string = ''.join(map(str,array))

в int_string сложенная строка

Объяснение:

map(str,array)

конвертирует массив в переменной array в тип str

было: [1,2,3] стало ['1','2','3']

''.join()

собирает массив в скобках в строку, разделяя символами перед точкой( в этом случае пустое место

было:

array = ['1','2','3']

''.join(array)

стало:

'123'

было:

array = ['1','2','3']

','.join(array)

стало

'1,2,3'

было

array = ['1','2','3']

'.А.'.join(array)

стало:

'1.А.2.А.3'

ПОКАЗАТЬ ОТВЕТЫ
oleh09156 oleh09156  15.10.2020 11:04

--- Python 3.7.0 ---

import typing  

from typing import List #Импортируем библиотеку, предоставляющую удобные классы для указания типов  

def JoinInteger(ToInt:List[str]): #Функция, склеивающая массив строк в целое число (если возможно)

   return int(''.join(ToInt))

   

def Caprekar(OrigNumber:str): #Функция, выполняющая описанные действия над числом. Принимает число В ВИДЕ СТРОКИ

   SortedNum = JoinInteger(sorted(list(OrigNumber), key = lambda digit: int(digit), reverse=True))  #Сортируем цифры в числе на основе их числового значения в порядке убывания

   SortedReversed = JoinInteger(str(SortedNum)[::-1].split())

   ToRet = str(SortedNum - SortedReversed)

   return ToRet

   

def FromFile(fname):  #Функция для считывания входных данных из файла

   with open(fname, 'r', encoding = 'utf-8') as Input:

       readed = Input.read()

       return readed

   

def Dump(fname, Value): #Записывает в fname значение Value

   with open(fname,'w', encoding = 'utf-8') as Output:

       Output.write(Value)

def main(): #Тело программы

   RawInput = FromFile('input.txt')

   IsCapr = False

   CaprCount = 0  

   temp = RawInput

   while (not IsCapr):

       NewNum = Caprekar(temp)

       print(temp, NewNum)

       if (NewNum == temp): Dump('Output.txt', f'{NewNum}\n{CaprCount}'); return

       temp = NewNum

       CaprCount += 1

if __name__ == '__main__':

   main()

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика