tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль! напишите программу
Паскаль! напишите программу по нахождению всех делителей данного натурального числа
нина412
2 29.07.2019 21:30
0
Ответы
Виника5634
03.10.2020 16:55
Var
n, i: integer;
begin
readln(n);
i:=n;
writeln('Делители числа ',n,':');
while i>0 do
begin
if (n mod i) = 0 then
write(i, ' ');
i:=i-1;
end;
read;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ukrainanadegda
08.04.2021 17:23
2^n python. нужно возвести в степень с for x in range...
mynameisNastia
08.04.2021 17:24
Складіть алгоритм та блок-схему до задачі: Потрібно наповнити водою порожню діжку місткістю 56 л, беручи воду з колодязя і використовуючи відро місткістю 8 л ...
nikemaxair55780
02.08.2019 08:10
Перевести 110010 из двоичной системы счисления в десятичную....
Tanecka2501
02.08.2019 08:10
Напишите программу нахождения всех четных чисел,кратных p, в диапазоне от n до м)...
mazurok3
02.08.2019 08:10
Перевести 756 из восьмеричной системы счисления в десятичную....
ali0002
29.11.2021 21:02
В некоторой части сети Интернет по запросу Берёза | Ель найдено 19000 тыс. стр., по запросу Берёза & Ель – 5000 тыс. стр., по запросу Ель – 10000 тыс. стр. Сколько будет найдено...
OmegaLULx
29.11.2021 21:01
Составьте следующий алгоритм с условием. Если Красная Шапочка увидит волка, то она идёт по другой дороге 1 начало 2 процесс выполнения действия 3 условие выполнения действия 4 процесс...
Гогенцоллерн
07.09.2019 10:00
Как называется программа (или устройство), которое выполняет кодирование и декодирование звука и видео?...
leryush1
07.09.2019 10:00
Скажите ответ только с решением. сообщение о том что ваш друг живёт на девятом этаже несёт 8 бит информации. сколько этажей в доме...
elisavetto4ka
07.09.2019 10:00
Крупный сайт, объединяющий различные универсальные серверы.что это? (...
Популярные вопросы
Очень решить тест по английскому языку, контрольная работа, очень важно...
3
В ряду - MgO, H2SO4, K2CO3,FeCl2,NaNO3,HCl - число формул оксидов и солей соответственно...
1
A conductor shaped, as shown in the figure carries a current of 25,8 A. If r1=0,003...
3
Прямоугольник и квадрат имеют одинаковощадь - 64 м. Чему равна длина прямоугольноесли...
1
Зобразіть на координатній площині всі точки (x;y) такі,що y = 4,x - довільне число....
3
Является ли человек частью географической оболочки?...
3
Почему крестовые походы в Иерусалиме были неудачными?...
1
1 Слова у фонетичній транскрипції записати буквами й підкреслити орфограму. [к̕...
3
Докажите, что политический лидер может организовать и повести за собой большие...
2
- It very much.Write a letter to your friend about Hayt.Напишите письмо своему...
2
n, i: integer;
begin
readln(n);
i:=n;
writeln('Делители числа ',n,':');
while i>0 do
begin
if (n mod i) = 0 then
write(i, ' ');
i:=i-1;
end;
read;
end.