Напишите программу нахождения всех четных чисел,кратных p, в диапазоне от n до м)

Tanecka2501 Tanecka2501    1   02.08.2019 08:10    1

Ответы
Kakanya Kakanya  30.09.2020 00:02
Var
n,m,p,i:integer;
begin
write('Введите N,M,P через пробел: ');
readln(n,m,p);
For i:=n to m do
if (i mod p = 0) and (i mod 2 =0)  then write(i,' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
кулибяка2 кулибяка2  30.09.2020 00:02
Вот держи, я даже оформил красиво! Var n,m,p,x,i:integer; Begin Write('Введите N >>> '); Readln(n); Write('Введите M >>> '); Readln(m); Write('Введите P >>> '); Readln(p); Writeln(''); X:=0; For i:=n to m do If (i mod 2 = 0) and (i mod p = 0) and (i <> 0) then Begin X:=x+1; Writeln(i,' - Чётное и кратно ',p); End; End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика