tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль даны натуральные
Паскаль даны натуральные числа n и k. написать программу вычисления выражения 1^k+2^k+3^k+4^k+…+n^k
katy994
3 20.07.2019 23:20
2
Ответы
Darkhan06
03.10.2020 09:14
// PascalABC.NET 3.1, сборка 1190 от 05.03.2016
begin
var n:=ReadInteger('n=');
var k:=ReadInteger('k=');
var s:=Biginteger(0);
for var i:=2 to n do s+=Power(Biginteger(i),k);
Writeln('Сумма ',s+1)
end.
Тестовые решения:
n= 10
k= 30
Сумма 1043651859661187698792930519525
n= 5
k= 2
Сумма 55
n= 38
k= 67
Сумма 8400313720757760689953535296227476513296331784292134843927352320607786766609162308796108536127867158913721
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Hurakan
19.10.2019 16:15
Написать программу вычисления стоимости покупки 5-ти товаров ниже таблица значений и начало решения, нужно доделать до конца! , кто шарит в информатике!...
misszhilinskay
22.07.2019 13:50
Записать в естественном виде: 3,456*10^5 и 10011*2^11...
superdmnomber1
22.07.2019 13:50
Время непрерывной работы на компьютере: а)не более 20 мин. б)не более 30 мин. в)не более 40 мин....
xKarishax
22.07.2019 13:50
Решить первый час работы рабочий изготавливает а деталей, за каждый последующий час - на d деталей больше, чем за предыдущий. разработайте программу, которая подсчитывает,...
Kirill20061337
16.04.2020 13:47
Назовите этоЭто смесь чайника, утюга и часов...
mashatemni
16.04.2020 13:47
1.Решить, используя цикл repeat Напишите программу, которая в последовательности целых чисел определяет сумму отрицательных нечетных чисел. Программа получает на вход...
Камила1э
16.04.2020 13:47
Написать программу которая в последовательности чисел находит среднее арифметическое трех значных чисел и выводит слово нет если таких чисел не существует программа...
999Fox999
29.07.2019 17:40
Дан целочисленный массив из 30 элементов. элементы массива могут принимать целые значения от –100 до 100 включительно. напишите алгоритм, позволяющий найти и вывести...
ученик1862
12.05.2020 17:04
3D моделирование – это ...A ) это некоторая часть окружающего мираВ) упрощенное представление об объекте С) объект, имеющий три измеренияD) процесс создания трехмерной...
Annamatveevvva8
12.05.2020 17:04
Hem 2 ye hemde 7 ye bolunen nece 2 reqemli eded var? ...
Популярные вопросы
Сделать комплексный анализ текста ...
1
Write two versions of each sentence, one for person one for person...
2
Найти наименьший общий знаменатель дроби 7/18 1/6 ...
1
Заполни пробелы. Важной деталью колесницы было(а) . Совершенствование...
3
Объясни пропущенную орфограмму Камин был большой, вылож_нный внизу...
2
выписать ,что собой представляла Великая Хартия вольностей,год ее...
2
Какая тактическая система изображено на рисунке быстрый прорыв позиционная...
2
2-й уровень сложности 5/12 7/16 3/8 е) 41/90 13/30 19/60 ж) 7/36...
2
Докажите, что управление страной разделилось надвое в 1608-1610 годах....
2
нада! Непрозоре коло освічується точковим джерелом світла і відкидає...
1
// PascalABC.NET 3.1, сборка 1190 от 05.03.2016
begin
var n:=ReadInteger('n=');
var k:=ReadInteger('k=');
var s:=Biginteger(0);
for var i:=2 to n do s+=Power(Biginteger(i),k);
Writeln('Сумма ',s+1)
end.
Тестовые решения:
n= 10
k= 30
Сумма 1043651859661187698792930519525
n= 5
k= 2
Сумма 55
n= 38
k= 67
Сумма 8400313720757760689953535296227476513296331784292134843927352320607786766609162308796108536127867158913721