Pascal уравнение написать программу решения уравнений вида (не обязательно квадратное) a*x^2 + b*x + c = 0. коэффициенты запрашиваются с экрана и могут быть любыми действительными числами. результатом работы программы является либо вывод корней уравнения, либо вывод какого-то сообщения. само уравнение тоже должно быть выведено на экран.

Iamboss11111 Iamboss11111    3   29.06.2019 19:20    0

Ответы
mary041 mary041  23.07.2020 16:50
Program a;
var D,a,b,c: real;
begin
Readln(a,b,c);
//a*X^2 + b*X + c = 0
writeln (a,'*X^2 + ',b,'*X + ',c,' = 0');
D:=b*b-4*c*a;
if (d<0) then writeln ('D<0!') else
if (d=0) then writeln ('X= ',(-b+sqrt(D))/2) else
if (d>0) then writeln ('X1= ',(-b+sqrt(D))/(2*a):0:1,'; X2= ',(-b-sqrt(D))/(2*a):0:1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика