Pascal ! 1. составьте программу, вычисляющую, сколько букв надо исправить в слове х, чтобы получилось слово y (слова x и y одинаковой длины). 2. составьте программу, определения номера первой буквы "а" в слове х. 3. составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове х чаще.

thefirststudent thefirststudent    3   28.05.2019 11:10    3

Ответы
nikita5000011111 nikita5000011111  25.06.2020 21:48
Задача 1.
var
  i,c: integer;
  x,y: string;

begin
  readln(x);
  readln(y);
  for i:=1 to length(x) do
    if x[i]<>y[i] then inc(c);
  writeln('Букв надо исправить = ',c)
end.

Задача 2.

var
  i: integer;
  x: string;

begin
  readln(x);  i:= 1;
  while x[i]<>'a' do inc(i);  // Здесь, в зависимости с какой буквой сравнивать, либо с русской, либо с англ.
  writeln(i)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика