Напишите программу вычисления суммы отрицательных значений функции q(w)=31w+31 на отрезке [a; b] с шагом h

diana9996 diana9996    2   21.09.2019 01:10    0

Ответы
cstslp0ahrl cstslp0ahrl  08.10.2020 05:56
PascalABC.NET:

Var
  Q,w, a,b,h, S: real;
Begin
  WriteLn('Q(w) = 31w+31');
  Write('a = ');ReadLn(a);
  Write('b = ');ReadLn(b);
  Write('h = ');ReadLn(h);
  S := 0;
  w := a;
  if (a < b) then
  begin
    if (h < 0) then exit;
  end
  else if (a > b) then
    if (h > 0) then exit;
 
  While (w <= b) do
  begin
    Q := 31*w+31;
    if (Q < 0 ) then
      S := S + Q;
    w := w + h;
  end;
  WriteLn('S = ',S);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика