Напишите программу. определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной площадке

BcezHaNKa BcezHaNKa    1   14.09.2019 10:40    4

Ответы
vasikstrowb vasikstrowb  07.10.2020 14:01
Program P1;
var z,x,y,p,e:integer;
begin
  write('Количество этажей = '); readln(x);
  write('Количество квартир на лестничной площадке = ');
  readln(y);
  write('Номер квартиры = '); readln(z);
  p:=(z-1) div (x*y)+1;
  e:=((z-(p-1)*x*y)-1) div y +1;
  writeln('Квартира ',z,' находится в ',p,' подъезде на ',e,' этаже');
end.

Пример:
Количество этажей = 9
Количество квартир на лестничной площадке = 4
Номер квартиры = 67
Квартира 67 находится в 2 подъезде на 8 этаже
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика