Напишите программу нахождения n! -произведения первых n натуральных чисел с использованием цикла с автоувеличением !

alb123 alb123    1   26.08.2019 07:30    1

Ответы
тараканеше тараканеше  05.10.2020 20:33
Var n,f,i:integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=2 to n do f:=f*i;
writeln(n,'! = ',f);
end.

Пример:
n = 6
6! = 720
ПОКАЗАТЬ ОТВЕТЫ
alina28042002 alina28042002  05.10.2020 20:33
/* C++ 17 */

#include <iostream>
using namespace std;

int main()
{
int n, f = 1;
cout << "n = ";
cin >> n;
for (int i = 2; i <= n; i++) {
f *= i;
}
cout << f << endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика