Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности 1, 2, 4, 8, 16, 32. в первой строке содержится n (1 ≤ n ≤ 50) – количество чисел. вывести первые n чисел прогрессии со знаменателем 2 и первым членом 1. с++

Сайка1111111 Сайка1111111    3   21.06.2019 23:00    2

Ответы
Nastyaluan Nastyaluan  17.07.2020 10:51
#include <stdio.h>

int main()
{
int n, i;
scanf("%d", &n);
if (n>=1&&n<=50)
{
for (i=1; i<=n;i*=2){
printf("%d ", i); }
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика