Напишите программу, которая находит все символы, встречающиеся в обеих переданных ей строках. входные данные на вход программы две символьные строки, каждая строка завершается символом "конец строки". выходные данные программа должна вывести все символы, которые встречаются в обеих строках, в порядке возрастания их ascii-кодов. если таких символов нет, нужно вывести слово 'no'. примеры входные данные qwerty asdqwhy выходные данные qwy входные данные qwerty 12345 выходные данные no pascal abc 1.8 программа должна быть составлена по теме множества

13t2t 13t2t    2   23.08.2019 12:20    9

Ответы
ФКЗенит1 ФКЗенит1  05.10.2020 14:35
Var set1: Set of Char;
    set2: Set of Char;
    s1, s2: string;
    i: integer;
    done: boolean;
    c: char;
begin
set1 := [];
set2 := [];
readln(s1);
readln(s2);

for i := 1 to length(s1) do
  include(set1, s1[i]);

for i := 1 to length(s2) do
  include(set2, s2[i]);

done := False;
for c := #0 to #255 do
  if (c in set1) and (c in set2) then
  begin
    done := True;
    write(c);
  end;

if not done then
  write('NO');

writeln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика