tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу, которая
Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).
DANIL79NR
1 27.06.2019 03:30
16
Ответы
veronichka1414
02.10.2020 12:43
Var
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
DOLBONAFT
20.10.2020 16:59
Какую клавишу нажала девочка? смотрите на фот...
dfhdfhf20022004
20.10.2020 16:40
1. Запишите числа в десятичной системе счисления 100101 (2), 56 (8), А (16) 2. Расположите числа в порядке возрастания 0110111 (2), 56 (8), 1Е (16)...
Anastasia0610201
18.09.2021 11:19
Скласти програму знаходження суми всiх чисел кратних трьом вiд 10 до как можно быстрее...
SandraBulitl
18.09.2021 11:16
умножить число a на b используя операцию сложения в виде блок схемы ( без доп переменной в коде это как то так for (i=0 i b i+++) a=a+a...
ruslan2003185
15.09.2019 01:10
Как перевернуть вот этот знак: ^ !...
Imdav88
15.09.2019 01:10
По информатике ! 1: представьте в развернутой форме: а) 4563; б) 1001012; в) ас616. 2: переведите число 74 из десятичной системы счисле ния в двоичную, восьмиричную, шестнадцатиричную;...
ludmilaels
05.10.2019 10:20
Брать ли xiaomi redmi 6 pro? и почему?...
ОлиПоп
05.10.2019 10:11
Составить словесный алгоритм и блок схему к .ввести 2 числа.если их произведение отрицательно, умножить его на -2 и вывести резельтат, в противном случае увеличить его в 3раза и...
Supernix
20.05.2020 08:29
с информатикой1. Скорость передачи информации 808 бит/с. Сколько байт передаст данный можем за 20 секунд?2. Среди приведённых ниже чисел найдите максимальное и запишите его в десятичной...
kirilnavrotskykiril
20.05.2020 08:28
Дизайн-құжат дегеніміз не? ...
Популярные вопросы
Аможет быть, кто - то на другом конце тоже пробует ее расчистить? обьясните запятую...
3
Кто нибудь ! нужен небольшой текст на тему если бы я был волшебником с глаголами...
3
Составить схемы предложений указать что является подлежащим и сказуемым ( обязательно...
1
З`ясуйте походження фразеологізмів: кривити душею, разом з`їсти пуд солі, виносити...
3
Байдарка 5ч шла со скоростью 4км.ч ,а оствльное время со скоростью 6км.ч. сколько...
1
Аквариум имеет форму прямоугольного параллелепипеда измерение которого равны 45...
2
Письмо другу (на ) про лагерь - начало (вступление) - основная часть ( в лагере...
1
Выбрать меню,в котором в названии блюд все согласные звуки твёрдые: салат,уха,компот;...
2
Выплата чугуна на уральских заводах в тыс. пудов 1860 г. - 14500, 1861г.- 14200,...
2
По таблице простых чисел ( см . второй форзац учебника пособия ; 4 ) найдите простое...
1
n,k:integer;
begin
Write('Укажите число и номер инвертируемого бита: ');
Read(n,k);
Writeln('Результат: ',n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557