Напишите программу формирования массива размером 5×5. замените в нем нечетные значения элементов на минимальноее значение элементов последней строки выведите на экран исходный и измененный массив
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017 // Внимание! Если программа не работает, обновите версию!
begin Writeln('*** Исходный массив ***'); var a:=MatrRandom(5,5,-99,99); a.Println(4); var min5:=a.Row(4).Min; for var i:=0 to 4 do for var j:=0 to 4 do if a[i,j].IsOdd then a[i,j]:=min5; Writeln('*** Результирующий массив ***'); a.Println(4) end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(5,5,-99,99);
a.Println(4);
var min5:=a.Row(4).Min;
for var i:=0 to 4 do
for var j:=0 to 4 do
if a[i,j].IsOdd then a[i,j]:=min5;
Writeln('*** Результирующий массив ***');
a.Println(4)
end.
Пример
*** Исходный массив ***
-65 20 -60 11 59
46 59 -28 65 -33
-34 37 73 -82 76
-57 68 26 85 82
44 -45 30 90 36
*** Результирующий массив ***
-45 20 -60 -45 -45
46 -45 -28 -45 -45
-34 -45 -45 -82 76
-45 68 26 -45 82
44 -45 30 90 36