(НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON) Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 2. (НАПИШИТЕ НА PYTHON) (НАПИШИТЕ НА PYTHON)

Tesckep Tesckep    2   16.03.2020 19:30    10

Ответы
Мухосранск462 Мухосранск462  11.10.2020 23:17

summ = 0

a = int(input())

while a != 0:

   if a % 7 == 0 and a % 10 == 2:

       summ += a

   a = int(input())

print(summ)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика