Написать программу вычисления подоходного налога по формулам: а) при сумме менее 2500 рублей налог не взимается, б) от 2500 до 10000 руб, берется 13% от суммы, в) при сумме более 10000 руб берется 1300 рублей плюс 15% от суммы превышающей 10000 рублей. указание: программу проверить при суммах 1000, 8000 и 12000 руб. ответы должны быть соответственно 0, 1040 и 1600 руб. на паскале

dmitryparshin dmitryparshin    2   16.06.2019 02:20    4

Ответы
DashaV19022001 DashaV19022001  12.07.2020 23:25
Program Nalog;{Uses crt}{Если надо}varz,x:real;begin
Write('Ввидите число  ');Read(x);If x<2500 then Writeln('налог = 0');
beginif (x>=2500) and (x<10000) thenz:=x*0.13;Writeln('Налог=',z);end;Beginif x>=10000 then z:=(x-1300)*0.15;Writeln('Налог=',z);{READLN - Если турбо поскаль или фрии}end;end.
Картинка снизу 
Только есть 1 проблемв с последним 


Написать программу вычисления подоходного налога по формулам: а) при сумме менее 2500 рублей налог н
ПОКАЗАТЬ ОТВЕТЫ
leonidbobnev leonidbobnev  12.07.2020 23:25
program name;//Имя программы
uses crt;
var 
a:integer;  
BEGIN  write('Введите сумму: '); readln(a);
  if a < 2500   
then write('Подоходный налог составляет: 0 рублей от суммы ',a, ' рублей');
     
if (a <= 10000) and (a >= 2500)   
then write('Подоходный налог составляет:', a*0.13 ,' рублей от суммы ',a, ' рублей');   
if a > 10000   
then write('Подоходный налог составляет:', (a-1300)*0.15 ,' рублей от суммы ',a, ' рублей');     
ReadKey;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика