Написать программу в паскаль. задано количество строк и столбцов матрицы и действительные значения ее элементов. сформировать и вывести транспонированную матрицу.

v0632039813 v0632039813    3   13.07.2019 02:40    1

Ответы
game108551 game108551  03.10.2020 02:25
Const
e=10000;
var
a:array[1..e,1..e] of real;
i,j,n,m:integer;
k:real;
begin
readln(n,m);
for i:=1 to n do
  for j:=1 to m do
  read(a[i,j]);
for i:=1 to n do 
for j:=i+1 to m do   
begin     
k:=a[i,j];     
a[i,j]:=a[j,i];     
a[j,i]:=k;   
end;   
for i:=1 to m do   
begin     
for j:=1 to n do 
write(a[i,j],' '); 
writeln; 
end; 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика