Написать программу в паскаль. дан произвольный текст. преобразовать его по следующим правилам: все буквы «о» заменяются на «оа», все пробелы заменяются символом «_», а запятые удаляются.

kapitan2001 kapitan2001    3   31.07.2019 07:50    4

Ответы
domaris246 domaris246  03.10.2020 18:22
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('>');
  s:=s.Replace('о','oa').Replace(' ','_').Replace(',','');
  Writeln(s);
end.

Тестовое решение
> "Дает корова молоко" - писать, конечно, не легко!
"Дает_кoaрoaва_мoaлoaкoa"_-_писать_кoaнечнoa_не_легкoa!
ПОКАЗАТЬ ОТВЕТЫ
zarina20178 zarina20178  03.10.2020 18:22
S- переменная текста
i- счетчик
readln(s);
for i:= 1 to length(s) do
 begin
  if (s[i]='о') then
 s[i]:='оа';
    if  (s[i]=' ') then
(s[i]='_')
if (s[i]=',') then
 s[i]:='';
writeln(s);
end.
   Вроде как-то так
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика