tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу в паскаль
Написать программу в паскаль abc для нахождения корней квадратного уравнерния y=ax^2+bx+c
Vita0814
2 22.05.2019 00:30
0
Ответы
Наталинас
17.06.2020 00:33
Var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Gasdsa
07.11.2020 10:46
В царстве фей все немного отличается от царства людей. Так, в начальной школе феи изучают странную математику. Ее основное отличие от обычной математики в том, что числа в ней...
Надюшка2000
02.03.2019 11:30
Текст объёмом 1024 бита располагается в оперативной памяти, начиная с байта с номером 10. каков будет адрес последнего байта, который занят данным текстом...
stepanoganezov
02.03.2019 11:50
2000х2000 пикселей ! скажите ответ?...
КундызДиас
02.03.2019 11:50
Номер 1 напечатать сумму элементов кратных одновременно двум или трем числового ряда 3, 6, 9, 2, 12, 2, 24 и 2 составить программу вычисления числового ряда для известного числа...
debchai123
02.03.2019 11:50
Сколько текстовых файлов объёмом 400байт можно записать на жёсткий диск, если используется таблица размешения файлов fat16 и ёмкость жёсткого диска равна 2гбайта...
sofka123890
02.03.2019 12:00
Пусть видеопамять компьютера имеет объём 512 кбайт. размер графической сетки – 640х480. сколько страниц экрана может одновременно разместиться в видеопамяти при палитре из 256...
bockovickof
02.03.2019 12:10
Алгоритм вычисления площади треугольника...
ома7
02.03.2019 12:10
Алгоритм определения месячной платы за расходы электроэнергии...
Tinka123
02.03.2019 12:40
Один стакан лимонада содержит 15 калорий, 1 кусок торта - 150 калорий, 1 драже тик-так - 2 калории. во время праздничного обеда буратино выпил 5 стаканов лимонада, съел 20 драже...
SuperMax2003rus
02.03.2019 13:00
Дано двузначное число .найти число десятков в нем...
Популярные вопросы
Морфологический разбор служебных частей речи берись за то к чему ты сроден...
3
Факторы влияющие на уровни жизни. примеры...
3
Составьте последовательность употребления продуктов по степени наибольшей...
3
Найдите рациональные корни уравнения 2x^4+7x^3-3x^2-5x-1...
3
Что общего между словами горох и горошина...
1
Найдите площадь прямоугольника длина которого равна 5 см а ширина 2см...
1
Вкаком слове букв больше ,чем звуков ? 1)язык 3)морковь 2)город 4) арбуз...
3
Жили были отец с матерью и было у них двое детей - старшая дочь - маша и...
2
Выпиши прилагательное в четыре столбика 1) рост 2) цвет глаз 3) цвет волос...
1
Из орфографического словаря выпиши по 5 слов в котором количество букв и...
2
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.