Написать программу в pascalabc.net удалить из строчки s символы + - * а потом заменить все символы на символы следующие по алфавиту.

damiramirov321 damiramirov321    1   13.09.2019 04:10    1

Ответы
лаьтслчлвт лаьтслчлвт  07.10.2020 11:04
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите строку:');
  s:=s.RegexReplace('[\+\-\*]',''); // удалили
  s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
  Writeln(s)
end.

Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика