Написать программу (паскаль)
в массиве хранится информация о стоимости 1 кг 20 видов конфет. определить, сколько стоят самые дешёвые конфеты . если таких несколько, то должен быть найден индекс первого из них .

260г 260г    1   29.10.2019 07:42    1

Ответы
saba22 saba22  05.08.2020 09:23

program test;

var a:array [1..20] of integer;

min, i, imin: integer;

begin

min:=a[19];

imin:=19;

for i:=1 to 20 do begin

a[i]:=random (151)+150;

write (a[i]:4);

end;

writeln;

for i:=19 downto 1 do begin

if a[i]<min then begin imin:=i; min:=a[i]; end;

end;

write (imin);

writeln;

write (a[imin]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика