Написать программу pascal abc, ! ) вводится 4-х значное число. : 1) вывести число это же число, в котором меняется местами 1 и 2 цифра, 3 и 4 цифра, например 1234=2143. 2) если в перевернутом числе 1 двухзначное число> второго , то вывести 1 двухзначное число , если нет, то 2 двухзначное число. например, 2143= 21< 43 , следовательно выводится 43. 3) найти произведение всех цифр, перевернутого числа. заранее ! )
a:integer;
b,c,d:byte;
Begin
Write('Введите четырёхзначное число: ');
ReadLn(a);
b:=a div 1000;
c:=(a div 100) mod 10;
d:=(a div 10) mod 10;
a:=a mod 10;
WriteLn('1: ',c,b,a,d);
WriteLn('3: ',a*b*c*d);
c:=c*10+b;
d:=a*10+d;
if c>d then WriteLn('2: ',c)
else WriteLn('2: ',d)
End.
Примеры работы программы:
Введите четырёхзначное число: 6547
1: 5674
3: 840
2: 74
Введите четырёхзначное число: 9753
1: 7935
3: 945
2: 79
Введите четырёхзначное число: 3149
1: 1394
3: 108
2: 94