tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу нахождения
Написать программу нахождения суммы всех чисел> заданного к при вводе до первого отрицательного.
andreweeoneoff
2 17.07.2019 06:50
2
Ответы
ИсхакТурдубеков
21.09.2020 16:22
//Pascal ABC.NET v3.0 сборка 1111
var
a,k,s:integer;
begin
readln(k); //вводим k
a:=0;
s:=0;
while a>=0 do //пока а >=0
begin;
if a>k then s:=s+a; //если a>k, тогда добавляем к s
readln(a); //каждый раз вводим в a
end;
writeln(s); //выводим s
end.
Пример ввода:
45
34
56
67
-2
Пример вывода:
123
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
super123jack
11.11.2020 18:14
Зачем нужна файловая система...
Am0nt
21.05.2019 01:47
Решить работу на алгоритмизацию строчно, заранее...
мирали3
21.05.2019 02:40
Для какого числа х истинно высказывание х 1 ^ ((x 5) - (x 3)) 1) 1 2) 2 3) 3 4) 4...
gjz123456
21.05.2019 02:40
Выполнить сложение в восьмеричной системе счисления 238+758 результат представить в двоичной системе счисления выполнить сложение в шестнадцатеричной системе счисления 1416+3в16....
Анастасия20041981
21.05.2019 02:40
Вычислите значение выражения в мбайтах 2 в 29 степени бит+0,125 гбайт , зарание...
Tori163
21.05.2019 02:40
Составьте на языке паскаль программу вычисления суммы всех нат.чисел, не превышающих заданного натурального числа n....
bogdansoroka20
21.05.2019 02:40
Составьте на паскале программу возведения в n-ую степень целого числа x...
ivan88001
21.05.2019 02:40
Составьте на паскале программу возведения в n-ую степень целого числа x....
DarkoRei
21.05.2019 02:30
Числа 1964 , 1966 пазиционная система,не знаю какая но какая то вот такая=2^8? 2^ : : )...
yla00458
21.05.2019 02:30
Среди двухзначных чисел выдать на экран все четные....
Популярные вопросы
Влетнем лагере отдыхало 87 семиклассников. 7 из них не любят компьютерные игры....
2
1)сколько десядков а числе 745? 2)сколько всего сотен в числе 49071? 3)сколько...
3
Причины июльской революции, итоги событий 1830-х годов...
3
Подготовьте сообщение древний вавилон короткое...
2
Напиши название продуктов , в которых есть эти витамины...
3
Прочитайте. справа, слева, самосвал, землеройка, страна, лампа, налево, направо,...
1
1. в каком предложении есть безличный глагол? а. потемнело в чистом поле б. пуганая...
3
Пятиэтажный дом построили верх ногами без чердака. какой высоты должна быть лестница...
1
Решить тест! заранее ! тест 6. обобщение повторения. текст вариант 2 а1. в каком...
3
Запишите число в стандартном виде: а)3800 б)0,00043...
3
var
a,k,s:integer;
begin
readln(k); //вводим k
a:=0;
s:=0;
while a>=0 do //пока а >=0
begin;
if a>k then s:=s+a; //если a>k, тогда добавляем к s
readln(a); //каждый раз вводим в a
end;
writeln(s); //выводим s
end.
Пример ввода:
45
34
56
67
-2
Пример вывода:
123