Написать программу на языке си .1. подсчитать количество прописных букв в строке. 2. удалить из строки самое длинное слово.

mavikon mavikon    3   24.06.2019 04:10    0

Ответы
Polinochka570 Polinochka570  19.07.2020 19:39
Написать програму которая считывает текст с клавиатуры, находит самое длинное число и определяет, сколько раз оно встретилось в тексте.
Код C++

#include <conio.h>
#include <stdio.h>
#include <string.h>
#include <iostream.h>
void main();
{clrscr();
char s[50];
char s1{}=" ";
char *p;
char *q;
char e[50];
int g,a;
cout<<"vvedite tekst:"<<endl<<endl;
gets(s);
p=strtok(s,s1);
while(p)
{if(*p==' ')
p=strtok(s,s1);
g=strlen(p);
cout<<endl<<g<<endl;
if(a<g)
{a=g;
*e=*p;
}
p=strtok(NULL,s1);
}
puts(e);
cout<<endl<<e;
getch();
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика