tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на pascal
Написать программу на pascal вычислить сумму квадратов вводимых чисел. числа вводятся, пока не будет нажат ноль.
Laurka11
1 15.09.2019 14:40
4
Ответы
Ariana20199
07.10.2020 17:28
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.
ПОКАЗАТЬ ОТВЕТЫ
Кузнечик0705
07.10.2020 17:28
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.
Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
qhahz
20.05.2021 10:43
Для какого целого числа ХЛОЖНО высказывание: (X 7) ИЛИ НЕ(X 6)? ответ:...
Thevalk3
27.11.2019 22:07
Вклетках а1,а2,а3 помещены коэффициенты квадратного уравнения.необходимо в клетки а4 и а5 записать формулы расчета квадратного уравнения.составте формулы.b excel...
киса819
27.11.2019 22:04
Из чего состоит система связи...
NadiaU0
16.11.2020 07:15
Как открыть программу скетчбук?...
linagalkinaa1
11.10.2019 14:19
Яделаю проект. тема: проблемы модернизации на примере реформ александра ii. написать-актуальность: цель: : гипотеза: заранее)...
maxkostin29rus
11.10.2019 14:18
Елси позвонить в телефон доверия то узнают об этом родители? ...
OlyaMonokova
11.10.2019 14:18
Подскажите как оформить красиво коллекцию марок! на урок....
IFRASHDIFRASHD
11.10.2019 14:18
Милые ! мне. определите объекты. ...
Thanks2y
11.10.2019 14:18
2. расскажите, что такое хиджра, и уточните значение этого события для- мусульманского вероучения.3. кто утвердил династийную власть в арабском халифате? 4. в каких...
elizaveta210605
11.10.2019 14:18
1. запиши звуковую модель названия картинки2. составьте схему предложениямалыши любят играть.они строят башни и крепости....
Популярные вопросы
Расскажите о назначении прикладных программ...
2
ів))) Потрібно зробити закладку до підручника з основ християнської...
3
Доклад по истории по теме все сводится к деньгам!...
2
Постройте квадрат, сторона которого ровна 37 см Найдите его периметр...
2
кусок меднего провода длиной 5 м имеет масу 430 г .какова масса...
2
нужно быстро решить мне жизнь:)...
1
Заполни таблицу , реши задачу. Купили 5 наборов ручек по 120 и...
2
Паспорт пісні Засвіт встали козаечньки...
1
Запишите множество всех трехзначных чисел в записи которых используются...
1
1 52. Упростите выражение: 1) 3(2x + 1) + 5 (1 + 3x); 3) 10 (n+m)...
2
//Версия 3.3, сборка 1611
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.
Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134