Написать программу на pascal "дана строка символов s, состоящая максимум из 250 символов. напишите программу, которая проверит является ли строка s палиндромом. примеры палиндромов: ‘cojoc’, ‘cazac’, ‘potop’, ‘rotor’."

mirvera2007 mirvera2007    3   13.08.2019 15:20    2

Ответы
Брат111111111 Брат111111111  04.10.2020 16:15
Var
s:string;
l,i:byte;
begin
readln(s);
l := length(s);
for i:= 1 to l div 2 do begin
if s[i] <> s[l-i+1] then begin
writeln('NO');
halt;
end;
end;
writeln('YES');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика