Написать программу: на ферме 40 животных,козы,коровы и овцы. вывести экран все возможные комбинации,при условии что коров в два раза больше чем коз. нужно,это информатика)
begin for i := 1 to 40 do begin koz := i; kor := 2 * koz; ov := 40 - (koz + kor); if ov < 0 then break; writeln('Овец: ', ov, ' Коров: ', kor, ' Коз: ', koz); end end.
i, kor, koz, ov: integer;
begin
for i := 1 to 40 do
begin
koz := i;
kor := 2 * koz;
ov := 40 - (koz + kor);
if ov < 0 then break;
writeln('Овец: ', ov, ' Коров: ', kor, ' Коз: ', koz);
end
end.