Написать программу которая рассчитывает 10!
использовать цикл с параметром ( счётчиком) и цикл с предусловием.
большое

Rostik559 Rostik559    3   09.11.2019 15:00    1

Ответы
yadianamelnik yadianamelnik  10.10.2020 12:02

Program fact10;

var

i:byte;

fact:longint;

begin

writeln('Цикл с параметром');

fact:=1;

for i:=2 to 10 do

fact:=fact*i;

writeln('10! = ',fact);

writeln('Цикл с предусловием');

fact:=1;

while (i<>1) do

begin

fact:=fact*i;

i:=i-1;

end;

writeln('10! = ',fact);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика