Написать программу, которая определяет, является ли строка палиндромом (на с++)

asem052 asem052    2   06.06.2019 03:50    4

Ответы
Chelovechena1 Chelovechena1  06.07.2020 11:52
#include <conio.h>
#include <iostream>
using namespace std;
int main()
{   
char s[255];   
bool palindrom=true;   
gets(s);     
for(int i=0;i<strlen(s)/2;i++)   
{       
          if(s[i]!=s[strlen(s)-i-1])       
          {           
          palindrom=false;           
          break;       
          }   
}   
if(palindrom)
cout<<endl<<"Palindrom";   
else
cout<<endl<<"Ne palindrom";   
getch();   
return 0;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика