Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива

Тотах Тотах    1   25.05.2019 06:30    0

Ответы
настя7603 настя7603  01.10.2020 11:21
Если паскаль, то - 

const n:=100; //в массиве пусть будет 100 элементов
var tarray:array[1..n] of integer;
max:integer;
i:=byte;
begin
{тут заполнение массива}
max:=tarray[1]; //думаем что максимум - это первый элемент
for i:=1 to n do 
 if max > tarray[i]
  then max:=tarray[i];//если встречаем элемент больше максимального - то он -новый максимальный 
write('Максимальный элемент - ', max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика