Написать программу для паскаля: массив а, состоящий из 10 целых элементов задан через random. все элементы массива разделить на 2 элемент. вывести на экран старый и новый массив.
Var ar:array[1..n] of real; i:integer; k:real; begin randomize; writeln('First array:'); for i:=1 to n do begin ar[i]:=random(100); write(ar[i]:4); end; k:=ar[2]; for i:=1 to n do ar[i]:=ar[i]/k; writeln; writeln('Final array:'); for i:=1 to n do writeln(ar[i]); end.
Const
n=10;
Var
ar:array[1..n] of real;
i:integer;
k:real;
begin
randomize;
writeln('First array:');
for i:=1 to n do
begin
ar[i]:=random(100);
write(ar[i]:4);
end;
k:=ar[2];
for i:=1 to n do
ar[i]:=ar[i]/k;
writeln;
writeln('Final array:');
for i:=1 to n do
writeln(ar[i]);
end.