Надо! составить программу, которая запрашивает вес пользователя р и его рост r в см, а затем, если выполнится условие р меньше или равно r-100, то сообщает "поздравляю. ваш вес в норме", в противном случае - "хорошо бы вам немного похудеть"
Program weight; Var a,b: real; Begin writeln('Введите ваш вес P'); readln(a); writeln('Введите ваш рост R'); readln(b); if a<=b-100 then writeln('Поздравляю. Ваш вес в норме') Else writeln('Хорошо бы вам немного похудеть'); End.
В приложении рабочий файл программы
Пояснения:
1. Переменным a, b присваивается значение real, так как рост и вес могут быть не целыми числами, а дробными.
2. окончания команд writeln, readln, сортируют этапы решения и ввода по строчкам, вместо вывода всё в одну строку.
3. После условия a<=b-100 НЕ ставится точка с запятой, так как это часть одного цикла условия (IF - если). если поставить точку с запятой, то программа будет не верна
P.s. Почему-то сервис не возволяет скачать файл программы. В общем скопируйте просто из начала решения тогда
Program weight;
Var
a,b: real;
Begin
writeln('Введите ваш вес P');
readln(a);
writeln('Введите ваш рост R');
readln(b);
if a<=b-100
then writeln('Поздравляю. Ваш вес в норме')
Else writeln('Хорошо бы вам немного похудеть');
End.
В приложении рабочий файл программы
Пояснения:
1. Переменным a, b присваивается значение real, так как рост и вес могут быть не целыми числами, а дробными.
2. окончания команд writeln, readln, сортируют этапы решения и ввода по строчкам, вместо вывода всё в одну строку.
3. После условия a<=b-100 НЕ ставится точка с запятой, так как это часть одного цикла условия (IF - если). если поставить точку с запятой, то программа будет не верна
P.s. Почему-то сервис не возволяет скачать файл программы. В общем скопируйте просто из начала решения тогда