На языке программирования паскаль составить программу перевода из десятичной системы счисления в систему счисления с основанием х, где х - целое число, определяемое по такому правилу: если 2-я буква фамилии учащегося находится в интервале от а до д, то х = 9; если 2-я буква фамилии учащегося находится в интервале от е до к, то х = 8; если 2-я буква фамилии учащегося находится в интервале от л до р, то х = 7; если 2-я буква фамилии учащегося находится в интервале от с до ц, то х = 6; если 2-я буква фамилии учащегося находится в интервале от ч до я, то х = 5.

alena13gerda alena13gerda    2   21.05.2019 03:30    1

Ответы
lykuanenkoartem lykuanenkoartem  01.10.2020 02:22

var
a: string;
x: integer;
begin
write('Введите слово: '); readln(a);
length(a);
if (a[2]='а') or (a[2]='б') or (a[2]='в') or (a[2]='г') or (a[2]='д') then x:=9;
if (a[2]='е') or (a[2]='ж') or (a[2]='з') or (a[2]='и') or (a[2]='й') or (a[2]='к') then x:=8;
if (a[2]='л') or (a[2]='м') or (a[2]='н') or (a[2]='о') or (a[2]='п') or (a[2]='р') then x:=7;
if (a[2]='с') or (a[2]='т') or (a[2]='у') or (a[2]='ф') or (a[2]='х') or (a[2]='ц') then x:=6;
if (a[2]='ч') or (a[2]='ш') or (a[2]='щ') or (a[2]='ы') or (a[2]='ъ') or (a[2]='ь') or (a[2]='э') or (a[2]='ю') or (a[2]='я') then x:=5;
writeln('Перевод: ', x);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика