На основании исходных данных необходимо написать программу и получить ответ. Рассматривается множество целых нечетных чисел, принадлежащих числовому отрезку
[-1000; 2000], которые делятся на 17 или 23 и не оканчиваются на 3 или 5.
Найдите количество таких чисел и максимальное из них. В ответе запишите два целых
числа: сначала количество, затем максимальное число,​

irada2004irada irada2004irada    3   21.10.2020 23:01    4

Ответы
Misaki59 Misaki59  20.11.2020 23:02

Объяснение:

Программа на Питоне:

a=[]

m=-1001

n=0

p=int(input('Сколько будет чисел: '))

print('Вводите числа:')

for i in range(p):

  a.append(int(input()))

for i in a:

  if ((i % 17)==0 or (i % 23)==0 ):

      s=str(i)

      if not(s[-1]=='3' or s[-1]=='5'):

          if i>m:

              m=i

          n+=1

print('Количество: ',n)

if n>0:

  print('Максимальное:',m)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика