Информатики, составить программу, складывающую предложенные числа так, чтобы получилось круглое число от 100 до 1000 на языке pascal.

Дэникс1 Дэникс1    1   09.06.2019 12:20    4

Ответы
natalya00786 natalya00786  08.07.2020 09:24
var
  x, y, z: integer;
begin
  writeln('-1 - конец ввода и вывод суммы');
  repeat
    readln(y);
    
    if (y < -1) then 
      writeln('Эм... Не, не съем: отрицательная цЫфра.')
    else
      if (y >= 0) then 
        z := z + y
      else
        if (y = -1) then
          if (z >= 100) then
            break
          else
            writeln('Не, не годится, прибавь ещё чуток, до сотни не дотягивает');
 
    if (z > 1000) then
    begin
      writeln('Всё, перевес. Сумма чисел больше 1000.');
      exit;
    end;
    
    until (false);
  writeln('Сумма примерно равна (если округлить) ', round(z / 10) * 10);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика