tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Даны два массива x(n) и y(n)
Даны два массива x(n) и y(n) . в каком из них больше ненулевых элементов? (на языке с++)
Lolkekcheburek228322
2 12.09.2019 02:00
1
Ответы
ЧакН0рис
07.10.2020 08:43
#include <iostream>
#include <cstdlib>#include <ctime>
using namespace std;
int main() {
srand(time(0));
const int n = 5;
int x[n], y[n], x0=0, y0=0;
for (int i = 0; i < n; ++i) {
x[i] = rand() % 5;
y[i] = rand() % 5;}
for (int i = 0; i < n; ++i) {
cout<< x[i]<<' ';}
cout << endl;
for (int i = 0; i < n; ++i) {cout << y[i] << ' ';}
for (int i = 0; i < n; ++i) {
if (x[i]) x0++;
if (y[i]) y0++;}
cout << endl;
if (x0 > y0) cout << 'x';
if (x0 < y0) cout << 'y';
if (x0 == y0) cout << '=';
return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
саша4265
20.05.2020 13:38
Разработать на Паскаль программу для вычисления:1) значения заданного арифметического выражения2) значения заданной функции c = x^2+y^2+sin(x), при x-y=0;(x-y)^2+cos(x), при...
gasha1234567890
20.05.2020 13:58
Дан текст из 450символов. Известно, что символы берутся из 32символьного алфавита. Каков вес данного текста в байтах?...
ОленкаБурковська
18.06.2019 11:20
Хотя бы 3-4 ! 1) дан одномерный целочисленный массив размерностью n. найдите количество элементов, которые кратны 3 (5). 2) дан одномерный целочисленный массив а, состоящий...
oe5d
18.06.2019 11:20
Написать программу в паскале, которая вычислит все двузначные числа,сумма цифр которых равна 12. только , как можно проще. алгоритм вычисления пришлите....
невидимка789657
30.11.2020 10:04
Правильно текст,числа,формулы....
Nikita20330
30.11.2020 10:03
Проанализируйте и сравните чем схожи сетевые компоненты? Назовите различия между ними...
Miller2005
04.09.2019 00:30
Написать программу нужно подсчитать сумму покупки 14 карандашей по 30 рублей, 10 красных ручек по 50 рублей, 9 синих ручек по 50 рублей. программа нужна на языке paskal...
Urinasonya
06.12.2021 12:54
Что такое компьютер? А) универсальное техническое средство для работы человека с информацией. Б) специальный блок, через который внешние устройства компьютера взаимодействуют...
odminsovet
06.12.2021 12:53
2) Укажите, какой смысл имеют следующие символы: А) { Б) В) § Г) $ Д) %...
FruitAPps
09.06.2019 03:50
Составить ) в pascal abc в последовательности действительных чисел a1, а2, аn есть только положительные и отрицательные элементы. вычислить произведение отрицательных элементов...
Популярные вопросы
Яка головна мета тоталітарних режимів в Італії, Німеччині , СРСР?...
1
Упростить многочлен записав каждый его член в стандартном виде 1,9ay⁴*(-6)ayz-9,49*17m⁸n...
2
красных шаров 9 штук, синих 5 штук, белых 2 штуки Какова вероятность того...
1
ваобще не понимаю добрые люди...
2
Монғол мемлекетінжеке басқарды. Жанында жаза білетін және басқа елдердің...
1
Правильно розставлено розділові знаки в реченні Лев, з мармуру набуваючивеличі...
3
Лимерик про школьную жизнь...
1
9, 10,11 тапсырмалар 71 бет керек ертенге дейн...
1
ТОЛЬКО УСЛОВИЕ СДЕЛАТЬ на рис 4 изображен план квартиры найдите площадь...
3
1)9|х|-2|х|-8=5|х|; 3)2|х|+3|х|-18=|х|-7|х|+15...
3
#include <cstdlib>#include <ctime>
using namespace std;
int main() {
srand(time(0));
const int n = 5;
int x[n], y[n], x0=0, y0=0;
for (int i = 0; i < n; ++i) {
x[i] = rand() % 5;
y[i] = rand() % 5;}
for (int i = 0; i < n; ++i) {
cout<< x[i]<<' ';}
cout << endl;
for (int i = 0; i < n; ++i) {cout << y[i] << ' ';}
for (int i = 0; i < n; ++i) {
if (x[i]) x0++;
if (y[i]) y0++;}
cout << endl;
if (x0 > y0) cout << 'x';
if (x0 < y0) cout << 'y';
if (x0 == y0) cout << '=';
return 0;}