Дан массив e(10). составить программу обработки массива: 1. положительные элементы массива заменить нулями. 2. определить число элементов массива равных 5. 3. найти сумму чисел, неравных 3. все это должно быть в одной , решите качественно, много . ах, да, все это на языке паскаль.

nikakoheleva14 nikakoheleva14    1   24.06.2019 04:50    2

Ответы
rufergem rufergem  19.07.2020 19:59
var sum,c,i,l:integer;
E:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do begin
read(e[i]);
if e[i]>0 then e[i]:=0;
if e[i]=5 then l:=l+1;
if e[i]<> 3 then sum:=sum+e[i];
end;
writeln('Полученный массив');
for i:=1 to 10 do
write(e[i]:4);
writeln;
writeln('Сумма чисел, не равных трем равна ',sum);
writeln('Число элементов массива, равных пяти равна ',l);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика